REQUIRES_CODEGEN_VERSION

 

This file header token allows you to specify that a minimum version of CodeGen is required in order to successfully process the template. If the version of CodeGen being used does not satisfy this requirement then processing will terminate and an error message will be displayed.

 

NOTE: This token was introduced in CodeGen 5.2.1 and earlier versions will not process this token correctly. If a template containing this token is processed by an earlier version of CodeGen then it will not be recognized as a valid token and the token will simply be propagated into the output stream. This will almost certainly cause the generated code to fail, and the presence of the token in your output file will be an indication of the problem.

 

File header tokens must be grouped together at the top of the template file.

Usage

<REQUIRES_CODEGEN_VERSION>5.2.1</REQUIRES_CODEGEN_VERSION>

Alternate forms

None

See also

Other file header tokens

 

 


Copyright © 2012  Synergex International, Inc.